2012/04/28

在 Ubuntu 手動安裝 Qt SDK

以前一向都是從套件庫直接安裝 Qt SDK:
aptitude install qt-sdk

今天 checkout 別人的 project 出來編譯時,發現套件庫中的 Qt lib 版本有點舊 (好像是 4.6 吧),乾脆直接去 Qt 官網抓檔安裝來裝。

裝好後無意間發現 OpenGL 的範例程式編譯時都會出錯,弄了半天原來是從套件庫安裝時會自動把 OpenGL lib 裝上去,但是官網的安裝檔不會處理相依性問題。所以要自己手動補:
aptitude install libgl1-mesa-dev libglu1-mesa-dev libglut3-dev 

沒有留言:

張貼留言